This project has moved and is read-only. For the latest updates, please go here.

WFN 2.0 Alpha (2015.06.11) testing.

Jun 15, 2015 at 6:51 PM
Edited Jun 15, 2015 at 6:52 PM

Donwloaded and installed 2.0 alpha, and I chucked €10 your ways seeing how I have been using WFN for over a year now.


nb. what formate do you prefer bug report in? and do you need my full system specs..?
Jun 16, 2015 at 3:42 AM
If I had money, I would donate, too. A program like this deserves a few dollars/euros towards development. I figured, anything between 5$ to 20$ should help keep this program on it's feet.
Jun 17, 2015 at 8:02 AM
Hi guys, thank you very much for your support :-)

Rocknrollkid, you can still click thousands of times on the codeplex ads to help a bit (I'm kidding, I bet it will only count for one anyway!) ;-) Thank you anyway, I appreciate your kind words.

Regarding the bug reports, you can post issues here but I guess it would be better to wait for the next update (working on it right now, it should be published today). There was a lot of "known" issues I thought not worse mentioning at first (hence the "alpha" tag), and many of them are fixed now.

I'm re-adding the "services window" (which I skipped when migrating to WPF) and I guess we'll be good to go for another alpha (even maybe a beta this time!).

Thank you again!

Jérôme (Khan)
Jun 17, 2015 at 4:46 PM
Note: I wont be able to release a new version today. I modified to many things and I have to finalize some things first.
I hope I'll be able to work on it tomorrow, if not it will have to wait till Saturday or Sunday...
Stay in touch :-)
Jun 17, 2015 at 6:48 PM
No rush mister :-)
Jun 19, 2015 at 6:20 AM
Wait, the ads that on your page go to your software? I thought they just went to Codeplex (aka Microsoft).
Jun 19, 2015 at 8:58 AM
They probably get a bigger part than I do, but yes, I get a little something :-)
Note: I tried again and again to upload the new alpha, but the site won't let me (getting an error each time). Looks down to me. Hopefully I'll be able to do it today...
Jun 19, 2015 at 11:15 PM
Does the error say server is down? If so, you can check on CodePlex if the servers are down or not. Read here: where it says "What do I do if I get an error message that the server is down?"

Hope this helps you.
Jun 20, 2015 at 6:18 PM
Nope the error does not give any useful info. I contacted Codeplex team on Twitter, we'll see. I cannot even browse the site without encountering random issues... Wait n' see...
Jun 21, 2015 at 9:01 AM
Looks like they fixed it all, I was able to upload the full version and the site runs way faster today :-)
Jun 22, 2015 at 9:15 PM
Edited Jun 22, 2015 at 9:15 PM
Running the latest Alpha, no bugs to report so far, loving the new interface...
Jun 23, 2015 at 8:37 AM
Thanks :-)

Glad you like it!

If you use Win 7, the menu button may look a bit weird (blue border and standard button background when hovering), I forgot to reset the default style so while it seems alright in Win 8.x and 10, it does not on 7. The fix is really easy of course, and already implemented, but I don't want to release a new version only for that one.

Did you encounter any loading time / performance issue? When accessing the connections list for instance? It's really slow on Win 10, but I wondered if it was because of the system itself or not.

Thanks again!

Note: for those who don't like the orange "accent" color, you can change it through the options. As of now, all colors can be chosen, but it results in a loooong unordered list, so I may change that for something easier (some standard color picker, probably), in a near future.
Jun 23, 2015 at 6:18 PM
Edited Jun 23, 2015 at 6:20 PM
Ok, first bug. No matter what I tried I kept getting error popup, on allow or block - had to skip in the end.

Jun 23, 2015 at 10:30 PM
second bug:

Opening up wfn.exe resullts in a 10+second delay before I can do anything in the window
Jun 23, 2015 at 10:34 PM
I will investigate for the first one. Regarding the second one, does it occur with the latest version released today? Because it should have been fixed... Thank you for your feedback anyway :-)
Jun 24, 2015 at 6:48 AM
Edited Jun 24, 2015 at 1:52 PM
Downloading todays version and the delay in opening is fixed.

Where do you we put feature requests btw..?

[update] keep getting a request for the same service/port/ip, Ive blocked it and allowed it a number of times now -

Jun 24, 2015 at 11:02 PM
Another update, the dreaded constantly asking for the same app over and over again despite a rule being created. In this instance its both the above system app/servicve and also Adobe flash player.
Jun 25, 2015 at 10:19 AM

Feature request can be put in the "discussions" page, as long as I don't get thousands of them in different posts ;-)
Regarding this bug, can you please check the created rules to ensure everything looks alright (if you have no clue, a screenshot could be helpful)? What parameters did you check in "Advanced"? None of them as per your screenshot?

Jun 25, 2015 at 4:29 PM

I ticked all the ticked all the available tick-boxes and clicked either allow or block and then either while later or after as reboot I got ask for exactly the same again.

Jun 26, 2015 at 2:12 PM
Edited Jun 26, 2015 at 2:13 PM
Another update on the re-prompting of services/apps for access etc, I have also spotted that its not inclduing the app name in the custom rule name like did.

Jun 28, 2015 at 7:01 PM
Edited Jun 28, 2015 at 7:01 PM
I am having an issue with setting WFN options. I have place WFN in C:/Program Files/Windows Firewall Notifier (not the x86 folder). I try to switch the options, like "Use an animated notifier" or "Minimize the console to system tray" to the left side (does left side mean enable or disable? It doesn't say for me). I click apply and the option stays. When I close WFN and re-open it, the options apparently have reset itself back to default.

EDIT: I am on Windows 7 64bit.
Jul 1, 2015 at 3:45 AM
So it has been 3 days since I updated to Alpha 3 2.0 and I have not been getting any notifications at all. I have tried 3 times a complete uninstall and reinstall and reset settings and rules, but still nothing. Is this a bug?
Jul 1, 2015 at 7:48 AM
It's directly related to the other bug you mentioned (with the settings), WFN notification program fails to retrieve / update the settings and crashes before it even appears. I created an issue about it and want to fix it ASAP but I was away for a few days (and then a bit ill :-P).
I'll try to work on it those days.
Jul 4, 2015 at 9:48 AM

Testing the latest alpha (2015.06.23 - v2.0 alpha 3) and my previous issue' seem to be resolved. As in Im not getting multiple prompts for the same app/access and its naming the custom rules as per the app/port/ip etc.

Nice one Wokan.

I would like to make a request, It would be useful to be able to copy any IP/Port to clipboard so I can check them in a browser. Also maybe we could have a default action setup so if the user double clicks on an IP its opens said value in a browser to do a WHOIS check.
Jul 4, 2015 at 10:26 AM
Edited Jul 4, 2015 at 10:26 AM
Got another rule bug, couldnt create either an allow/block rule -

Jul 10, 2015 at 4:01 AM
Edited Jul 10, 2015 at 4:02 AM
So I downloaded 2.0 alpha 4 today and the issue with the notifier.exe spam in task manager happened, but it is not as bad as before. I was using WFN for maybe about a minute and then I checked with process hacker and found a bunch of notifier.exe processes there, but they didn't stay and removed them self after a short while.

Also, how do I set WFN to just prompt on outbound connections? I only saw "Allow" "Block" and "Block then prompt" I don't really want WFN to block then prompt, I just want it to prompt.

And lastly, the settings are now working without resetting back to default. Nice fix, but you should show if left or right side is disable or enable so people aren't confused (I was a little confused at first lol).

EDIT: Forgot to mention, WFN seemed to have slowed back down on start up like it was in alpha 2.
Jul 10, 2015 at 9:20 AM
Thanks guys,

In the latest release, you can enable back logging to gain more information about what's happening. It should prove helpful for me to understand what's happening (note that the error.log file is not used anymore, as of now everything will go to wokhan.windowsfirewallnotifier.common.log, it will change soon ; please also note that depending on the current user's rights, the log file will be written either in the WFN install folder or in the corresponding appdata one).

Rocknrollkid, having multiple processes at a given time is expected (each of them being triggered when an outgoing connection is blocked), what was an issue is that there was more and more never-closing notifier.exe, eating all CPU and memory. This is what I fixed. Anyway, I'll have a look at how to improve the behavior you saw to keep only one shared notifier.exe (I have an idea but not enough time this week).

Regarding your request, you cannot have "prompt" only: Windows blocks the connection first, and this is what triggers the WFN notification. It's not about filtering (what WFN does not as it's not a firewall), it's about notifying :-)

For the toggle switches not being clear enough, since many people seem to be confused about whether they are enabled, I'll probably improve this (I already did, setting their forecolor to gray when off, and to the currently selected accent color when on, but it looks like it didn't help at all :-) ).

Finally, you should not encounter any "slow start" as I didn't change this part. Maybe you had way more open connections this time?


Jul 10, 2015 at 9:50 AM
Edited Jul 10, 2015 at 9:59 AM
Enabling logging now, but PM you any logs as not posting them publicly etc.

[update] any attempt to get into settings or security logs results in an exception and the app crashing then closing.
Jul 10, 2015 at 10:08 AM
Thanks and sorry to hear that!
Are you using an admin account or a standard user? You can manually modify the WFN.config file which should be in %appdatalocal%\wokhan solutions\wfn to enable logging for the current user.
Unfortunately I'm leaving now for a few days, so I won't be able to investigate.
Jul 10, 2015 at 11:20 AM
Edited Jul 10, 2015 at 11:21 AM
Admin user

Only file in that folder is called user.config, what line do I need to edit to enable logging..?
Jul 11, 2015 at 2:55 AM
Edited Jul 11, 2015 at 2:58 AM
False alarm on the slow start-up issue. It's not happening anymore.

Also, looking at b1k3rdude prompt messages, I noticed 2 things. One, there is a check box with no label next to it. Two, there use to be an option to create a rule for it. Is this automatic now?
Jul 11, 2015 at 3:17 AM
Edited Jul 11, 2015 at 3:26 AM
New issue. This seems to happen when I have set WFN to "Block and prompt". I am getting an error message saying "Unhandled exception has occured in a component in your application. If you continue, the application will ignore this error and attempt to continue. Access to path C:\program Files\Windows Firewall Notifier\Wokhan.WindowsFirewallNotifier.common.log is denied" If I click continue, WFN will crash with an error message that says "The exception unknown software exception (oxe0434352) occured in the application at location 0xfd03b3dd". I can confirm I am using .Net framework 4.5.2 on my system. Do I need another version?

Right after the error messages, WFN, once again, spammed repeatedly notifier.exe processes in task manager (I use process hacker). I think this happened because the 2nd error message I got was spamming my system and I couldn't get rid of it.
Jul 18, 2015 at 12:01 PM
Edited Jul 18, 2015 at 12:01 PM
New issue. This seems to happen when I have set WFN to "Block and prompt". I am getting an error message saying "Unhandled exception has occured in a component in your application. > Right after the error messages, WFN, once again, spammed repeatedly notifier.exe processes in task managet.
Same here.
Aug 5, 2015 at 10:30 PM
Any news on this now that Windows 10 is out..
Aug 7, 2015 at 10:32 PM
I am sure the developer is working hard on the next version. He should take as much time as he needs so he can get it done right.
Aug 8, 2015 at 8:03 AM
Hi guys,

Thank you for your detailed messages. Unfortunately I have less free time those days since I'm back at work (I mean my real one :-) ), so it gets harder to fix those bugs. No ETA, but I won't leave WFN in a unfinished state anyway. I will keep you in touch, I really hope I'll be able to fix everything before the end of the month but cannot promise anything...
Thank you for being patient :-)

Jérôme (Khan)
Feb 23, 2016 at 7:33 PM
Hi b1k3rdude, ROCKNROLLKID,

I've been working on fixing several bad bugs, and I'll be doing a new release (Alpha 5) soon. When that release is out, can you please re-check if your issues are still happening? I suspect most of the non-crashing issues mentioned here will not be fixed, but I want to be sure I'm not going to chase ghosts.

Also, if they are still present, would you mind (re)posting them in the "issues" section (see "issues" tab above), and only one crash/bug per opened issue? I'll help me keep track of what I need to fix. And yes, I'll be fixing them! :)
Feb 23, 2016 at 9:07 PM

Hi Dan

As I haven’t heard from you in a while I found another similar app to WFN, called WFC. It essentially does the same job but with none of the issues that the version of WFN I had been using had.

Kind regards


Feb 23, 2016 at 11:18 PM
I use WFN because it is open-source and WFC is not open-source, so I hope the developers still can release an update for WFN.